Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

LJ U3 LabVIEW Example "U3 eAIN Example.vi" control more LJs

LJ U3 LabVIEW

  • Please log in to reply
3 replies to this topic

#1 grizzly.k

grizzly.k
  • Members
  • 2 posts

Posted 17 June 2015 - 04:18 AM

Hi,

 

I have three LJ U3-LV connected to an USB Hub and will only read analog Voltage. Everything works fine until the recognition of the last LJ.

I tested it a while with other ID numbers but nothing helped. Finally it occurs that, if I connect a 4th LJ U3 it will be possible to read the other 3 LJs.

Does anyone else know this problem and has a solution? I think an update of "LJUD_OpenLabJackS.vi" will fix the problem.

 

Best regards

Chris



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 17 June 2015 - 07:01 AM

Do all 3 look the same in Windows Device Manager?

 

Do all 3 show up in LJControlPanel?

 

Do all 3 show up if you run LJUD_ListAll.vi with DeviceType=3 and ConnectionType=1?

 

Does it make a difference in LabVIEW whether you open them by LocalID or SerialNumber?

 

Make sure only 1 program is running at a time.  For example, only LJControlPanel, or only LabVIEW.

 

Have you tried different hubs?  Also try a different computer as it could be a Windows issue.



#3 grizzly.k

grizzly.k
  • Members
  • 2 posts

Posted 18 June 2015 - 06:50 AM

All 3 LJs look the same in Windows Device Manager.

 

All 3 LJs are available in LJControlPanel.

 

All 3 LJs show up in LJUD_ListAll.vi

 

I plugged in the LJs directly to the Computer without hub but the problem is still present. I always run only one program at a time.

 

How can I open the LJ with the SerialNumber? I tried already different ID numbers but this didn't fix the problem.

 

I think the problem is LJUD_OpenLabJackS.vi because of it is not possible to handle the last opened LJ.

 

I solved the problem with the LJUD_Close.vi. Now I always close all Labjacks and open only the one I need for one measurement.

 

Thank you



#4 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 18 June 2015 - 11:47 AM

In your calls to OpenLabJack, make sure FirstFound is FALSE when using multiple devices.

 

Confirm that ListAll shows that each device has a unique local ID, and then make sure you pass those different local IDs to your different OpenLabJack calls.

 

To open by serial number you just pass in the serial number for pAddress, rather than a local ID.  Try opening all 3 by serial number and see if that makes a difference.

 

http://labjack.com/s...ers-guide/4.2.2





Also tagged with one or more of these keywords: LJ U3, LabVIEW

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users