Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

Motor communication failure


  • Please log in to reply
3 replies to this topic

#1 Aro

Aro
  • Members
  • 13 posts

Posted 17 March 2015 - 03:31 PM

So we have a device with a UE9-Pro and a 12VDC motor being controlled via a LJTick-RelayDriver and an SSR.  Off of the same LJTick-RelayDriver we are also controlling another SSR that powers on/off some AC heaters.  Everything else on the device and the UE9 are working fine, but as soon as the motor turns on we loose communication with the UE9.  We figured it had to do with either EMIs from the motor or SSR or with the internal power supply being overdrawn when the motor kicks on (the internal power supply also powers the UE9).  So in our trouble shooting we removed the motor from the device and powered it off of an external power supply.  When that external power supply was plugged into the same outlet as our device we lost communication, but if it was plugged into another outlet (even if the motor itself was placed inside the device) everything worked fine.  We've tried grounding and shielding everything we could and even tried plugging everything into a pretty high-end power isolater/conditioner, but nothing seems to work as long as the motor is drawing power from the same outlet as the UE9.  Any suggestions you may have would be greatly appreciated.  

 

Thanks a ton



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 19 March 2015 - 08:46 AM

Are you using USB?  Can you try Ethernet instead?

 

 

Do you have to power-cycle the UE9 to regain communication?  Failure mode D here:

 

http://labjack.com/s...ication-failure

 

How about mode C?



#3 Aro

Aro
  • Members
  • 13 posts

Posted 20 March 2015 - 12:22 PM

We have two computers, the newer tablet seems to be Failure Mode D (simply turning the device off and then on can restore communication) while the older CPU seems to be Failure Mode C (we have to close the DAQfactory software and disable/enable the USB).

 

We have tried a bunch of things and the problem is almost certainly some kind of EMI or other transient.  When we run the device with the motor via ethernet there are no communication issues and everything works fine.  For our application, however, we need to be able to use USB.

 

We also tried a different motor and had no problems.  The specs are a little thin for both motors, but the one that works is <http://www.amazon.co...sundheits0c-21>and the one causing all the problems (but the one we ultimately would like to use) is <http://www.amazon.com/gp/product/B00858SYYS/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1>.  And as I mentioned before, even when the motor is turned on/off and powered from a separate power supply we still lose communication if it is plugged into the same outlet as the device.

 

What would you suggest we do to shield or eliminate the interference?

 

Thanks again 



#4 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 20 March 2015 - 12:54 PM

The app note linked in post #2 has a lot of avenues you can explore.  These jump out at me:

 

1.  Is the problem caused by turning the motor on/off, or simply the fact that the motor is running?  If you can determine this, it can help target where to fight the EMI.

 

2.  Use the watchdog to recover autonomously.

 

3.  Try to isolate if a particular connection or connections to the UE9 are picking up the EMI and letting the problem in, then you can tackle those specifically.

 

4.  Get one of the recommended 5m cables.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users