Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

Streaming and Logging Data from U6 with DAQFactory

streaming logging

  • Please log in to reply
1 reply to this topic

#1 alkaram

alkaram
  • Members
  • 18 posts

Posted 18 December 2014 - 11:54 AM

I am trying to quantify the impact of the electromagnetic noise from a solenoid valve on a pH electrode that is connected to a LabJack U6. I have attempted to build a simple Faraday cage around the valve to block some of this noise and I am trying to test if it works.

 

I have set up a script in DAQFactory to start streaming a pH channel at 12000 Hz, start logging this pH data stream, and then turn valve on and off to observe the impact on the voltage output of the probe. I believe I am running into timing issues when logging the streamed data. I receive an error message towards the end of the script. The data still logs to the specified file, but the length of my data doesn't match what I would expect based on my scan rate. These imgur images show the script for my stream/logging, starting stream script (based onStreamOneChannel) , and the error message I receive. 

 

I had previously changed the DAQFactory clock to use the system time by adding UserTime.dll to the DAQFactory directory. I have since deleted this, re-started the program, and still run into the same problems. '

 

I've also tried streaming and logging through the LJStreamUD and it worked great. But I want to be able to run a script to turn the valve on and off via the relayboard (to maintain constant time intervals) and I wasn't sure that was possible from this simple interface. 

 

Any suggestions on how to proceed? I've also posted a similar question on the DAQFactory forum



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 18 December 2014 - 04:52 PM

LJStreamUD does not have any way to command outputs, and it claims the USB connection on the U6 so you can't talk to the U6 with another program while LJStreamUD is open, so what you are trying to do in DF makes sense to me.  I looked at your imgur and don't spot anything obviously wrong there.  Lets see if AzeoTech has any ideas on their forum.  Perhaps attach your CTL there if you did not already.





Also tagged with one or more of these keywords: streaming, logging

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users