Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

I2C by U3-LV-OEM

I2C

  • Please log in to reply
1 reply to this topic

#1 Ruppi66

Ruppi66
  • Members
  • 1 posts

Posted 01 December 2014 - 02:48 AM

Hello,

we have a Problem with the I2C-Interface by a U3-LV-OEM.

We get SDA(J3/7) und SCL(J3/8) directly by the J3-Connectors, but get not Signal.

Needs what to be observed in programming and/or a mapping of the Pins to be.

Other signals/Pins assinged to the Interface already works, but this would mean a Change on the circuit board.

Thank you in advance and sorry for my bad english

Best regards

Jörg

 



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 01 December 2014 - 02:42 PM

Hello,

 

I think you are confused about what pins can be used as digital I/O lines?  J3 is a header location on the board which provides holes for FIO4, FIO5, FIO6, and FIO7.

http://labjack.com/s...sers-guide/2.12

 

All FIO are okay for usage as I2C data lines, if you wire a 2.4k to 4.7k pull-up resistor between the FIO line and VS.  The spot on the board labeled as "SCL" is NOT FOR I2C, the SPC and SCL lines are intended for internal testing, and resetting of the hardware.  Again, you must use FIO, CIO, or EIO lines for I2C communication.  To understand what pins are FIO, EIO and CIO, reference the U3 user's guide linked above.





Also tagged with one or more of these keywords: I2C

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users