Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

StreamStart Problem

differential channel

  • Please log in to reply
1 reply to this topic

#1 pascal

pascal
  • Members
  • 1 posts

Posted 14 November 2014 - 10:42 AM

Hello,

I found your product really nice but I do not manage to work with it!

I hope you will beable to help me.

My objective is to sample one chanel in diffential mode at 1 KHz.

 

Then in this way I write a cpp program but I have an error . 

 

Illegal AI Command ...

 

 

I do not manage to know why I have this error, I hope you can help me! maybe you have also an example which can already work?

 

 

You will find my program enclosed. 

 

Many thanks!

Attached Files

  • Attached File  main.cpp   8.58KB   242 downloads


#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 17 November 2014 - 10:00 AM

When you use a differential channel, only a gain of x1 is allowed.  For the "gain" parameter you are actually passing an index, not the actual gain value, so you want to pass 0 to get a gain of 1.

 

http://labjack.com/s...users-guide/4.8

 

Looking at the example list, the best for you might be "VC6 Stream Example".

 

http://labjack.com/s...rt/u12/examples




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users