Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

LabJackPython, Exodriver Installation Issues and libusb-1.0

exodriver U3 libusb

  • Please log in to reply
2 replies to this topic

#1 RolandAskew

RolandAskew
  • Members
  • 1 posts

Posted 02 November 2014 - 02:56 PM

Hello,

 

 

I am attempting to install the LabJackPython module to use with a U3 Device.

 

 

LabJackPython requires the Exodriver to be installed. I have downloaded and attempted to install Exodriver, but it requires the libusb-1.0 packages. The Make command crashes to console when trying to load the libusb package. The instructions I was following are here: http://labjack.com/b...ver-ubuntu-1004

 

The libusb-1.0 packages do not appear to be available anymore through apt-get, there is a libusb-dev package available but exodriver does not recognise it.

 

I have manually downloaded a git repository labelled libusb-1.0-dev, but even when placed in the exodriver download folder and renamed libusb-1.0, Make still crashes.

 

 

I am using Ubuntu 14.04, Python 2.77.

 

 

Thank You,

 

Roland



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 03 November 2014 - 10:31 AM

Hello,

 

What is the output of `make`ing liblabjackusb?

 

Also, what is the output of `apt-cache policy libusb-1.0-0-dev`?

 

Thanks,

Rory



#3 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 03 November 2014 - 01:17 PM

Also, we now include a script in the Exodriver download for installation. Check the Mac OS X and Linux Exodriver page in the "In-depth Linux build instructions" section for the current build instructions:

 

http://labjack.com/s...ac-os-x-drivers

 

However the script will run into the same "make" issues, so please respond back to our previous response to help further on the issue.





Also tagged with one or more of these keywords: exodriver, U3, libusb

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users