Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

Streaming channel 193 resets CIO0 low


  • Please log in to reply
8 replies to this topic

#1 paul_ds

paul_ds
  • Members
  • 7 posts

Posted 11 June 2014 - 02:19 AM

During initialization I set CIO0 high. I then initialize streaming mode with channel 193 only. However, once streaming commences, CIO0 is reset! Any ideas? Thanks



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 11 June 2014 - 05:06 AM

Are CIO1 and CIO2 affected as well? If so, your U6 is in extended multiplexing mode. In this mode the MIO lines (which are shared with CIO) will be set in order to control external multiplexors. Extended multiplexing mode is enabled whenever an analog channel greater than 15 and less than 192 is used.



#3 paul_ds

paul_ds
  • Members
  • 7 posts

Posted 11 June 2014 - 05:50 AM

Yes, CIO1 and CIO2 are both affected. I'm using the manufactures default settings and have not intentionally set any analogue channels. How can I turn the extended multiplexing mode off? Here's the code that initializes the stream:

 

AddRequest(m_lDeviceHandle, LJ_ioCLEAR_STREAM_CHANNELS, 0, 0, 0, 0);

AddRequest(m_lDeviceHandle, LJ_ioADD_STREAM_CHANNEL, 193, 0, 0, 0);

GoOne(m_lDeviceHandle);

eGet(m_lDeviceHandle, LJ_ioSTART_STREAM, 0, &dValue, 0));



#4 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 11 June 2014 - 08:08 AM

Let's try updating your firmware: http://labjack.com/support/firmware/u6

 

It looks like there was a related bug fixed in 1.26.



#5 paul_ds

paul_ds
  • Members
  • 7 posts

Posted 13 June 2014 - 02:03 AM

I've checked the firmware and it's up to date (1.39)



#6 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 13 June 2014 - 06:26 AM

I ran the following three tests with firmware 1.39:

 

1) Set CIO[0:2] output high. Stream AIN0, AIN1, and 193. CIO[0:2] remain set to output high.

2) Set CIO[0:2] output low. Stream AIN0, AIN1, and 193. CIO[0:2] remain set to output low.

3) Set CIO[0:2] input. Stream AIN0, AIN1, and 193. CIO[0:2] remain set to input.

 

We must have missed a detail somewhere. Can you send a program that demonstrates the problem to our support email: [email protected]



#7 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 13 June 2014 - 06:31 AM

I think I found it. The first channel in a scan must be an AIN.



#8 paul_ds

paul_ds
  • Members
  • 7 posts

Posted 13 June 2014 - 07:48 AM

Yep, that fixed it - thanks.

 

Is having AIN as the first channel in the scan a general requirement? Or is it only necessary to prevent the CIO lines from changing?



#9 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 13 June 2014 - 08:54 AM

An AIN in the first channel is a general requirement for U-series devices. T-Series does not have this requirement.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users