Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

ethernet connection failure when using media convertor


  • Please log in to reply
4 replies to this topic

#1 pxh100

pxh100
  • Members
  • 2 posts

Posted 08 September 2013 - 01:33 AM

Hi,

We are just getting started with our first labjack. Communications with the UE9 via USB and Ethernet without fiber optic cables are fine however when a pair of media convertors with a short length of fiber in between are used we cannot connect to the UE9.

Our laptops can communicate fine via the media convertors and fiber.

 

The media convertors are Startech part number MCM110ST2 , 10/100 MultiMode ST  rated for a connection upto 2km.

We have tried the media convertors in auto detect mode, they set the connection as 10Mb 1/2 duplex

We have also tried in manual mode 10Mb 1/2 duplex (plus all other possibilities)

Pings fail 100% when fa

 

We have tried the UE9 setup with a fixed ethernet addres, or with DHCP  both work without the media convertors/fiber in the circuit

but fail with the media convertors/fiber.  (media convertors/fiber work fine with laptops on auto or 10Mb 1/2 duplex.

 

Wireshark shows the expected exchange of packets for DHCP  (discover, request, offer ack) over wire connection, but we never

get an "DHCPack" when the UE9 is given the ip address over fibers.

 

We are using the latest firmware versions on the web site and did the firmware updates and initial setup via USB.

We  used the LJ control with USB panel to set either the fixed or DHCP addressing.

 

We really need the fiber connection for electrical isolation.

Any suggestions of what we should try next.

 

I can send the wireshark saved files if necessary.

 

Paul

 

 



#2 Tom Lawton

Tom Lawton
  • Members
  • 14 posts

Posted 09 September 2013 - 09:45 AM

Hi-

 

well I know UE9s can work OK over fiber- We installed one at the pinnacle of Burj Khalifa, on the end of a few hundred feet of fiber- which is, incidentally, the tallest (not highest!) ethernet port (and UE9) on the planet ;-)

 

Differences from your case: The converters are from B+B, and have never given any trouble. The UE9 is running a fixed IP, and whatever firmware was current in 2010 when we installed the system...

Can you try a fixed IP for starters...? No reason it should make a difference, but something to try at least ;-|

 

Good luck!

 

Tom



#3 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 09 September 2013 - 10:02 AM

Yes, I would try with a static IP first.  Get the UE9 working with a static IP without the fiber link.  Confirm that Ping works when the UE9 is connected, and fails when the UE9 is disconnected.  Then add the fiber link and try Ping again.  Perhaps try putting a switch between the media converter and the UE9, rather than connecting the UE9 directly to the media converter.



#4 pxh100

pxh100
  • Members
  • 2 posts

Posted 09 September 2013 - 02:39 PM

Adding a switch between media convertor and UE9 works.

Sounds like I should test a different brand of media convertor.

 

Thanks



#5 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 10 September 2013 - 04:04 PM

Adding a switch between media convertor and UE9 works.

Sounds like I should test a different brand of media convertor.

 

Thanks

 

We've ran into a small number of hubs/switches in the past that just seem to have issues with a UE9 for no known reasons.  Different switches with the same setup would work where one wouldn't. 

 

Another option would be to use our new T7, which has newer/faster Ethernet hardware than the UE9 does.  It would probably work a bit better in that situation.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users