Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

Error With LJControlPanel and LJSelfUpgrade


  • Please log in to reply
1 reply to this topic

#1 4Strings

4Strings
  • Members
  • 13 posts

Posted 28 August 2013 - 09:27 PM

Hi,

I am having a problem using both the LJControlPanel and LJSelfUpgrade programs. Whenever I run the .exe file (both latest versions) I get an error message.

 

When I run the LJControlPanel I get this message:

[attachment=1234:Capture.JPG]

The full text is:

 

System.IO.FileNotFoundException: Could not load file or assembly 'LJUDDotNet, Version=3.24.0.0, Culture=neutral, PublicKeyToken=9d6c109908595016' or one of its dependencies. The system cannot find the file specified.

File name: 'LJUDDotNet, Version=3.24.0.0, Culture=neutral, PublicKeyToken=9d6c109908595016'
   at LJControlPanel.LabJackDefaultPanel..ctor()
   at LJControlPanel.MainForm.InitializeComponent()
   at LJControlPanel.MainForm..ctor()
   at LJControlPanel.MainForm.Main()
 
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
 

 

When I try to run the LJSelfUpgrade program I get this error message:
[attachment=1235:Capture2.JPG]

 

I went to the registry but could only go as far as "[HKEY_Local_Machine\Software\Microsoft\Fusion", within "Fusion" there is only one entry titled "(Default)" whose type is "REG_SZ" and has no set value:

[attachment=1236:Capture3.JPG]

There are only three folders under "Fusion" titled "GACChangeNotification", "NativeImagesIndex", and "PublisherPolicy".

 

What is wrong and how can I get the LJ programs to work???

 

 

Many thanks,

4Strings



#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 29 August 2013 - 11:37 AM

It looks like the LJUDDotNet.dll .NET assembly cannot be loaded, usually indicating it wasn't installed correctly. Try installing with the latest installer and see if that helps. The current UD driver is 3.35 and it looks like you are trying to install 3.24:

 

http://labjack.com/support/software

 

If that doesn't help, go to the \Program Files (x86)\LabJack\Drivers ("Program Files" on 32 bit Windows) folder and run InstallLJUDNET.exe as administrator. To run as administrator right mouse click InstallLJUDNET.exe and select "Run as administrator".




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users