Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

LabJackScriptingAddition.osax for Mac OS 10.7?


  • Please log in to reply
1 reply to this topic

#1 equipoise

equipoise
  • Members
  • 3 posts

Posted 05 May 2013 - 08:34 AM

I'm trying to resurrect an old AppleScript script that I used to drive a U12 some years ago. Seems I can't get it working because the LabJackScriptingAddition.osax I found in the forum isn't functioning with my MacBook Pro running OS 10.7.4 as I have things configured. I've installed the version of the osax from 2006 and can load its dictionary and compile a script, but the osax doesn't seem to qualify as an application when the script is run and tries to utilize the osax's dictionary. The U12 itself is ok, as I was able to get LabJackPython to work with it in the simple tests I did, but it's no can do with AppleScript. Also, I'm unsure about whether I need to install the LabJackNoHID.kext. I had previoously used the Exodriver_NativeUSB_Setup, which installed the LabJackHID.kext. Does this conflict with or coexist with the LabJackNoHID.kext that apparently need to accompany the scripting addition? What's the current version of this I need?r I tried using Xcode (I'm pretty newbie there) to build the scripting addition, but failed on a newere (i386) MacBook PRo and an old G4-based macBook. Is the project for newer Macs available? Can anyone describe what I need to install and perhaps give a step-by-step? -- equipoise

#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 06 May 2013 - 12:11 PM

The LabJackNoHID and LabJackHID kexts look like they are doing the same thing and preventing the Apple HID driver from claiming the U12, so there should be no conflicts there. Looking at the forums I haven't seen activity on this subject beyond a 2006 topic:

https://forums.labja...?showtopic=1136

Unfortunately I haven't worked with AppleScript or building an osax, so I will not be much help in that area. One thing to check is that the source code project's settings is building a binary for your Mac's processor type (ex. i386).

Also, note that the ScriptingAdditions is not using a driver released by us and is using its own IOKit code (ljackmacx.c/h).


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users