Jump to content

As of July 17, 2015, the LabJack forums here at forums.labjack.com are shut down. New registrations, topics, and replies are disabled. All forums are in a read-only state for archive purposes.

Please visit our current forums at labjack.com/forums to view and make new posts. To post on the current forums, use your labjack.com login account. Your old LabJack forums login credentials have been retired. There are no longer separate logins for labjack.com and LabJack forums.


Photo

watchdog not disabled


  • Please log in to reply
3 replies to this topic

#1 Rabinovich

Rabinovich
  • Members
  • 2 posts

Posted 13 June 2012 - 08:25 AM

hello, our problem: code like AddRequest(lngHandle, LJ_ioPUT_CONFIG, LJ_chSWDT_RESET_DEVICE,1, 0, 0); AddRequest(lngHandle, LJ_ioSWDT_CONFIG, LJ_chSWDT_ENABLE,8, 0, 0); GoOne(lngHandle); worked, but ErrorHandler(ePut(lngHandle, LJ_ioSWDT_CONFIG, LJ_chSWDT_DISABLE, 0, 0)); does not work. What is wrong?

#2 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 13 June 2012 - 02:28 PM

hello,
our problem:
code like

AddRequest(lngHandle, LJ_ioPUT_CONFIG, LJ_chSWDT_RESET_DEVICE,1, 0, 0);

AddRequest(lngHandle, LJ_ioSWDT_CONFIG, LJ_chSWDT_ENABLE,8, 0, 0);

GoOne(lngHandle);

worked, but

ErrorHandler(ePut(lngHandle, LJ_ioSWDT_CONFIG, LJ_chSWDT_DISABLE, 0, 0));

does not work. What is wrong?


The code looks correct. Which part doesn't work? Do you get an error message? Is the device continuing to reset?

#3 Rabinovich

Rabinovich
  • Members
  • 2 posts

Posted 14 June 2012 - 12:53 AM

We did not get any error message. Watchdog is active and reboot labjack repeatedly.

#4 LabJack Support

LabJack Support
  • Admin
  • 8677 posts

Posted 19 June 2012 - 03:38 PM

We did not get any error message.
Watchdog is active and reboot labjack repeatedly.


Have you tried disabling the watchdog using LJControlPanel to make sure it can be disabled that way?


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users